UPUPW全系列最新版Apache/Nginx/Kangle版本对比及下载


UPUPW PHP套件包括Apache、Nginx、Kangle三大版本,大家下载之前请根据网站程序所需功能组件先对比再下载。

UPUPW 绿色服务器平台
服务环境 Apache Nginx / Kangle
PHP版本 PHP5.2 PHP5.3 PHP5.4 PHP5.5 PHP5.6 PHP5.2 PHP5.3 PHP5.4 PHP5.5 PHP5.6
A/N新版 A1510 A1510 A1510 A1510 A1510 N1511 N1511 N1511 N1511 N1511
PHP7.0 PHP7.0 A1512 PHP7.0 N1512
K最新版 PHPX/ASP/ASP.NET全能环境K2.1
支持系统 Windows 2003/2008/2012/2016;
XP/Vista/Win7/Win8.1/Win10; 32/64位
不支持
Win2003/XP
Windows 2003/2008/2012/2016;
XP/Vista/Win7/Win8.1/Win10; 32/64位
不支持
Win2003/XP
线程方式 Thread Safe(执行时会进行线程安全检查) Non Thread Safe(执行时不进行线程安全检查)
执行方式 ISAPI(以DLL动态库的形式使用) FastCGI(以单一线程来执行操作)
进程管理 Multi-Processing Module(MPM) UPUPW独创PHP-CGI双向引擎 / Kangle内置PHP-CGI管理
PHP多线程 NO Pthreads PHP多线程极速处理模块 NO
PHP切换 NO 仅Kangle版支持虚拟主机绑定多版本PHP同时运行自由切换
Web管理 NO 仅Kangle版支持Web在线管理虚拟主机,访问控制等
数据库 MariaDB数据库、MySQL数据库、SQLite数据库、SQL Server接口、Oracle接口
数据管理 phpMyAdmin   /   UPUPW面板数据库便捷管理
FTP服务 FileZilla server FTP
安全防护 独具UPUPW无进程安全防护机制, 具有注入/跨站防护、隐藏Apache/Nginx头部信息、隐藏PHP头部信息、禁止未绑定域名访问等功能
网站数量 支持虚拟主机可根据需要建立无数网站(服务器上具体数量需考量硬件配置和站点访问量)
域名绑定 支持主域名、二级域名、三级域名、泛域名等多种形式的多域名绑定(支持转码后的中文域名绑定)
反向代理 域名解析到服务器后支持代理虚拟主机(反向代理)、域名转发、端口隐藏
控制面板 UPUPW 智能控制面板
服务开关 支持一键开启或关闭Apache+PHP+数据库服务 支持一键开启或关闭Nginx/Kangle+PHP+数据库服务
端口更改 支持Apache、数据库端口更改 支持Nginx/Kangle、数据库端口更改
端口检测 支持Apache、数据库端口占用情况检测 支持Nginx/Kangle、数据库端口占用情况检测
数据升级 支持网站数据库特性由旧版本升级为新版本
密码重设 支持数据库密码重设功能
高配引擎 A/K无需此功能 N支持PHP-CGI高配引擎
功能组件 支持Apache及PHP功能组件开启与关闭 支持Nginx/Kangle及PHP功能组件开启与关闭
性能适配 支持低配主机、高端主机根据性能及负载一键优化运行环境
环境配置 支持服务器生产环境及本地开发测试环境PHP配置的一键调换
配置备份 支持UPUPW集成包配置文件的备份与还原, 内含出厂配置, 配置乱了一键还原
系统服务 UPUPW全系列版本均支持系统服务在开机、重启和注销后都保持在线工作状态以适应服务器生产环境
Gzip压缩 默认已开启Gzip压缩传输
伪静态 A/K默认已开启Rewrite伪静态,支持.htaccess文件 N默认已开启伪静态,upupw独创的up-rewrite.conf文件
Pathinfo 默认已支持php的pathinfo路径模式
SendMail PHP SendMail E-mail服务器邮件传输代理程序
oAuth NO 支持oAuth协议 NO 支持oAuth协议
缓存组件 MemCached数据缓存服务
加速组件 Xcache Xcache/OPcache Xcache Xcache/OPcache
解密组件 Zend Optimizer ionCube Loader ionCube Loader Zend Optimizer ionCube Loader ZendGuardLoader
ionCube Loader
PHP调试 Xdebug
硬件建议 CPU/2.0GHz↑ 内存/1GB↑
使用建议 服务器/本地


UPUPW PHP环境集成包分为Apache、Nginx、Kangle版,这三者跟IIS一样都是Web服务器,都有自己的优势,大家可以根据喜好自由选择!

UPUPW PHP环境集成包是按照PHP版本来划分的,根据不同扩展组件对PHP版本的支持不同,每个PHP版本所包含组件有所差异。如果网站需要特定组件支持才能运行请选择下载含有对应组件的PHP版本。

如果您是PHP程序开发者可以根据自己需求来选择版本,以下主要是针对PHP程序使用者的说明。

为什么要这样来划分版本呢?

因为PHP官方还没更新大版本的前提下PHP开发者都会固定在一个PHP版本上进行PHP程序和组件的开发,当PHP官方做一个大版本的更新比如从PHP5.2.X更新到PHP5.3.X后会添加一些新的PHP特性和舍弃一些旧的PHP函数,这样很容易导致PHP5.2.X上开发的程序运行于PHP5.3.X中出现不可预计的错误和没有对应PHP组件的情况。

典型的例子:

ShopEX程序开发在PHP5.2.X上对应的组件Zend Optimizer只有TS的PHP5.2.X版本,Zend Optimizer到PHP5.3.X就改为Zend GuardLoader了,所以如果ShopEX程序的研发平台还停留在PHP5.2.X上就只能运行在装有Zend Optimizer的TS版PHP5.2.X上了。

另一个实例,Discuz!X2版本在PHP5.4.X上运行会出现前台栏目显示正常后台版块栏目文字无法显示的情况,如果您的网站已经很完善不想升级Discuz程序的话就只能运行于低版本的PHP上了,这也是PHP版本不兼容的情况。

所以UPUPW环境集成包按照PHP版本划分主要原因就是让大家手中的PHP程序在UPUPW集成包中都能运行起来,大家选择UPUPW的时候请先看下自己手中的PHP程序有什么运行环境要求然后再选择合适的版本下载!

特别推荐:

根据以上问题UPUPW选择了Win上支持IOCP模型的Kangle作为服务器内核,支持不同虚拟主机绑定不同PHP版本同时运行,并且支持PHP版本切换功能,满足不同网站程序对PHP版本的需求,自带web后台在线管理使用更为方便!

12人参与评论【点击评论】